Atrasi-2079-Vox

フリーランスウェブデザイナーArata-Atrasi-Takamiのブログ。服・靴・育児ときどき開発。

Tag Archives: OS X

Mac App Store内の画像が表示されない時の対処

  • 投稿日:2013/03/20

久しぶりのMacネタです。

Mac OS X 10.6.6以降より追加され、今ではお馴染みとなったMac OS X向けアプリケーションダウンロードサービスの「Mac App Store」ですが、結構前から私の自宅のマシン環境下でちょいと不具合が出ておりました。
しかし、それほど焦っていなかったので大分放置しておりました。

その症状とは…

Mac App Store内の画像が表示されない!

1

こんな感じで。なにこれひどい。

 

Safariを使っている方ならたまーにネット上で見かけるかも知れない、この「?」マーク。これは本来ここに表示されるべき画像ファイルが見つからなかった時、いわゆる画像ファイルのデッドリンク状態の際に表示されるものです。

まー再起動したりだとかキャッシュをクリアした時だとか再読み込みした時だとか、何かの拍子に改善されてみたりみなかったりでしたが、取り敢えず目的のアプリケーションはちゃんとダウンロードできますし、別に「サムネイル画像出ないくらいいいか」みたいな感じで、私の生来のズボラな性格のおかげでずーっとこのまま放置してたんですね。

 

しかし、気になるは気になる…。どれ、ちょっち調べてみっぺか。
というわけでググってググって調べてみましたところ、Appleサポートコミュニティに当該症状でのスレッドが立っておりました。

App Store の画像が表示されない

 

ふむふむ…。このスレッドを読み進めていくと、どうやら下記の2つの条件が揃うとこの不具合が出る可能性がある模様。

  • OSのバージョンがOS X 10.8であること
  • 使用しているルータがNECのAtermシリーズであること

むむむ…!!!

めっちゃ私じゃん

 

実を言いますと、家の他のマシン(OSのバージョンは10.7)だとかでは同様の症状は出ていませんでした。
そんでもってBUFFALOのルータを使っている時は特にこういう症状は出ませんでした。
うーん…そういえばOSもルータもタイミング的に一緒くらいだったかも…。

何でしょうね。スレッド内のレスによると「ルータDHCPとMacとのやり取りでコケているような感じ」だそうで、なんかこの組み合わせだとネットワークとかDNS関係で何かバグがあるんですかね〜。

 

で、以下が対処法です。

ルータ側のDNSを確認

まずはルータ側のDNSの状態を確認します。ブラウザのURLに「192.168.0.1(Atermルータの初期設定ローカルIP)」みたいに打って、ルータにアクセスします。認証を求められるので「ユーザ名:admin」「パスワード:設定したパス」を入力してログインします。メニューの中から「情報」→「現在の状態」で接続先状態を表示し、その中の「WAN側プライマリDNS」「WAN側セカンダリDNS」の値をメモします。

 

Mac側のDNSの設定

次にMacのシステム環境設定を開き、ネットワークの項目を選択します。
右下にある「詳細」メニューを開き「DNSタブ」を選択します。「DNSサーバ欄」に先ほどメモしたプライマリDNS・セカンダリDNSの値をそれぞれ下の「+」ボタンを押して追加します。その後「OK」→「適用」を押します。

ちなみに上記方法ではルータに設定されているDNSをMacに設定していますが、GoogleのDNSを設定する方法もあるそうです。まーどっちが良いとか悪いとかっていう程のものでもないでしょうから、お好きな方で構わないんじゃないでしょうか(適当)。

AppStoreの表示が変な時は・・・・/風まかせ

 

上記の設定をしたあと、Mac App Storeを再起動してみます。

ブラボーーーー!

3

無事に画像が表示されるようになりました。
もし同様の症状でお悩みの方がいらっしゃいましたら、一度お試しください。